Back to overview
Degraded

CosmicGuard Network Instability

Oct 30 at 08:18pm GMT
Affected services
Cosmicguard

Resolved
Nov 02 at 03:51pm GMT

We are not seeing any more issue. This incident seems to be resolved. We will continue to monitor it.

Updated
Nov 02 at 10:50am GMT

We are currently observing widespread packet loss and connection drops affecting services protected by CosmicGuard. The issue appears to impact all of their PoPs, as disruptions are being reported across every location. Our team has already notified them, though it’s likely they’re aware, given that this outage seems to affect all customers, not just us.

Updated
Oct 30 at 09:49pm GMT

We have monitored Cosmicguard for a while and it seems to be stable now for our locations (FRA, ASH, DAL). Incident has been resolved

Created
Oct 30 at 08:18pm GMT

We are currently experiencing high packet loss across all PoPs for services protected by CosmicGuard DDoS Protection. Our team has reached out to CosmicGuard; however, this appears to be a widespread issue affecting all of their customers. We will continue to monitor the situation and provide updates as more information becomes available.