Back to overview
Downtime

Ashburn & Miami Connectivity Issues

Oct 25 at 09:23pm BST
Affected services
[N70] - Ashburn Game Node #1
[N90] - Miami Game Node #1
[US] - Premium VPS | NODE - 131
[US] - Premium VPS | NODE - 139
[US] - Premium VPS | NODE - 149
[US] - Premium VPS | NODE - 153
[US] - Premium VPS | NODE - 161

Resolved
Oct 25 at 10:22pm BST

All services are fully restored. Thank you for your patience and understanding.

Updated
Oct 25 at 10:12pm BST

Services are slowly restoring and becoming available. We are still monitoring.

Created
Oct 25 at 09:23pm BST

We are aware of service disruptions affecting our Miami and Ashburn locations. Our engineering team is actively investigating the issue and working to deploy a fix. We appreciate your patience and will restore full service as soon as possible.