Service Outage - Bacau, Romania
Resolved
Oct 18 at 05:00pm BST
The outage affecting our Bacau, Romania location has now been resolved. All impacted services are fully operational. Thank you for your patience while our team investigated and fixed the issue.
Affected services
Created
Oct 18 at 04:50pm BST
We are currently experiencing a service outage in our Bacau, Romania location. Our team is actively investigating the issue and working on a resolution. Updates will be provided as soon as more information is available.
Affected services