Connectivity issues affecting Ashburn and Dallas (Cosmicguard)
Resolved
Jul 6, 2026 at 10:41am UTC
Between approximately 02:00 and 03:00 BST today, CosmicGuard applied further changes to the affected mitigation rules. Our monitoring shows connectivity has recovered across the previously impacted ISPs and locations, and the issue now appears resolved.
If you are still experiencing connection problems to Ashburn (VA) or Dallas (TX), please open a ticket and include MTR logs from the affected source so we can investigate further.
Please note: the inbound (ingress) throughput cap of approximately 500 Mbps remains a separate, known issue. It is not expected to be resolved in the near term. We will update this status page if that changes.
Affected services
Created
Jul 5, 2026 at 11:20pm UTC
We are aware of connectivity issues affecting services in our Ashburn (VA) and Dallas (TX) locations.
Our upstream DDoS mitigation provider, CosmicGuard, has identified a mitigation rule desync across their network. Depending on which of their locations your traffic routes through to reach Ashburn or Dallas, you may experience:
- Connections being blocked or timing out, particularly from certain ISPs (internet providers)
- Intermittent reachability to some external destinations, including certain public DNS resolvers
- You or your users, including players connecting to game servers, being unable to reach services hosted in these locations
Separately, inbound (ingress) download throughput is capped at approximately 500 Mbps in some cases. This is a known issue that has been present for a couple of months. It relates to a Cloudflare Magic Transit (MT) problem on CosmicGuard's side, and they intend to raise it with Cloudflare to improve throughput going forward.
CosmicGuard has applied several changes since we escalated, but we are not yet seeing consistent improvement. We remain in active contact with their team and are continuing to push for a full resolution.
We will post further updates here as we have more information.
Affected services