Back to overview
Resolved

Scheduled Maintenance - NODE-12

Jul 7, 2026 at 9:00am UTC  –  Jul 7, 2026 at 10:00am UTC
Affected services
[EU] - Premium VPS | NODE - 12

Resolved
Jul 7, 2026 at 10:00am UTC

Maintenance ended

Created
Jul 7, 2026 at 9:00am UTC

We will be performing scheduled hardware maintenance on NODE-12 to resolve the intermittent stability issues some services on this node have recently experienced. Work includes a physical inspection of the server and a BIOS/firmware update.

Services hosted on this node will be offline for the duration of the maintenance. We expect the work to take up to 1 hour, though actual downtime should be shorter. No action is required on your part; affected services will return automatically once maintenance is complete.
We apologise for the disruption and appreciate your patience while we address this.