Back to overview
Maintenance

Storage Hardware Replacement - NODE-150

Jun 9, 2026 at 9:30am UTC  –  Jun 9, 2026 at 10:19am UTC
Affected services
[EU] - Budget VPS | NODE - 150

Resolved
Jun 9, 2026 at 10:19am UTC

The NVMe drive has been replaced. The NODE is up and running again and the services will be available shortly. Maintenance completed successfully

Updated
Jun 9, 2026 at 10:19am UTC

Maintenance ended

Created
Jun 9, 2026 at 9:30am UTC

We're carrying out planned hardware maintenance to replace a storage drive on the infrastructure behind NODE-150. A brief service interruption is possible while the drive is replaced, and performance may be slightly reduced for a few hours afterward as data resynchronizes in the background. We expect minimal disruption and no action is required on your part. We'll post an update here as soon as the work is complete.