Back to overview
Maintenance

Scheduled maintenance: Storage Hardware Replacement - NODE-182

Jun 8, 2026 at 9:30am UTC  –  Jun 8, 2026 at 10:30am UTC
Affected services
[EU] - Budget VPS | NODE - 182

Resolved
Jun 8, 2026 at 10:30am UTC

Maintenance has been completed successfully. Services are up and running. We will continue to monitor and make any necessary adjustments.

Created
Jun 8, 2026 at 9:30am UTC

We will be carrying out scheduled hardware maintenance on one of our nodes to replace storage hardware and restore full storage redundancy.
During the window, services on the affected components may be briefly unavailable while the hardware work is performed. Following the swap, you may notice reduced performance for a few hours while data is resynchronised in the background. No data loss is expected and no action is required on your part.
We've scheduled this during a low-traffic period to minimise disruption and will post updates here as the work progresses.