Back to overview
Downtime
Emergency Maintenance - NODE-124 Cooling Optimization
May 30, 2026 at 11:20am UTC
Affected services
[EU] - Extreme VPS | NODE - 124
Resolved
May 30, 2026 at 12:00pm UTC
Following the maintenance work, cooling improvements were successfully implemented and the server returned to normal monitoring status. No hardware replacement was required.
Affected services
Created
May 30, 2026 at 11:20am UTC
NODE-124 was placed under emergency maintenance following an automated thermal alert triggered by one of its storage devices. Monitoring detected elevated temperatures on a NVMe drive, exceeding our internal warning threshold.
As a precautionary measure, emergency maintenance was initiated to inspect and optimize the server's cooling and airflow configuration.
Affected services