Network Connectivity Issues - Bacau, Germany
Resolved
May 15, 2026 at 1:20pm UTC
The network incident affecting services in Bacău, Romania have been resolved since
The upstream internet provider at the datacenter has restored connectivity, and all affected services are operating normally again. Our team has continued monitoring the environment following recovery to ensure platform stability and performance.
We appreciate your patience while the provider worked to resolve the issue.
Affected services
Created
May 15, 2026 at 11:00am UTC
We are aware and currently investigating a network incident impacting services hosted in Bacău, Romania. The issue has been traced to an upstream internet provider at the datacenter facility affecting external routes. Connectivity via RCS RDS should not be affected.
Our infrastructure team is actively coordinating with the provider while they work to restore normal connectivity. At this time, some users may experience increased latency, intermittent connectivity, or temporary service unavailability affecting systems routed through the Bacău region.
Affected services