Back to overview
Maintenance

Maintenance: UPS Replacement - Bacau (RO)

May 12, 2026 at 6:00am UTC  –  May 12, 2026 at 7:00am UTC
Affected services
[N30] - Romania Game Node #1

Resolved
May 12, 2026 at 7:00am UTC

Maintenance ended

Created
May 12, 2026 at 6:00am UTC

🕒 Maintenance Window
Start: Tuesday, 12 May 2026, 07:00 UK Time (10:00 EEST)

End: Tuesday, 12 May 2026, 08:00 UK Time (11:00 EEST)

📝 Description
We are performing a critical replacement of a Uninterruptible Power Supply (UPS) unit at our Bacau (Romania) datacenter to ensure continued power redundancy and hardware reliability.

⚠️ Expected Impact
Downtime: This node will experience a brief period of unavailability (estimated 5–10 minutes) within the window as power is cut and restored to the rack.

Servers: All game servers and instances hosted on GAMES-NODE-30 will be automatically rebooted once power is restored.

Note: If your services do not come back online automatically, please open a support ticket.