Back to overview
Degraded

Network Outage | UK

Apr 8, 2026 at 11:21pm UTC
Affected services
[EU] - UK Web Node
[N50] - UK Game Node #1
[SQL50] - UK Database Node #1
[EU] - Premium VPS | NODE - 14
[EU] - Premium VPS | NODE - 17

Resolved
Apr 8, 2026 at 11:29pm UTC

This has been resolved now

Updated
Apr 8, 2026 at 11:25pm UTC

Cosmicguard is aware of this issue and they are currently investigating further.

For more information please check: https://status.as30456.net/cmnqoavlq05i1s5biogcu6stj

Created
Apr 8, 2026 at 11:21pm UTC

We are aware of the connectivity issues for services located in the UK. We have contacted the upstream provider and are awaiting further information and a resolution.