Scheduled Network Maintenance - Frankfurt (GERMANY)
Resolved
Jan 27, 2026 at 04:16pm UTC
Maintenance completed with success. Very minimum disruption, traffic levels are good.
If you experience any issues moving forward please contact Support.
Affected services
Updated
Jan 27, 2026 at 03:34pm UTC
Scheduled work has been completed. Currently monitoring the traffic levels.
Affected services
Updated
Jan 27, 2026 at 03:17pm UTC
We will be performing the the switch in approx. 15 minutes at 3:30 PM UTC
This might cause a short disconnection for couple of minutes.
Affected services
Created
Jan 27, 2026 at 03:00pm UTC
We will be performing a scheduled network infrastructure upgrade at our Frankfurt, Germany datacenter to improve stability and increase network capacity.
Impact: During this maintenance window, we will be re-routing traffic to newly deployed core network equipment.
Scope: This affects all services hosted in the Frankfurt region, including VPS, Dedicated Servers and B2B/Enterprise customers.
Service Disruption: Customers may experience a brief period of packet loss or connectivity drops. We anticipate the actual service interruption to last no longer than 5 minutes.
We will provide more accurate time frames within the scheduled time tomorrow.
Our team has already staged and pre-configured the new hardware to ensure a seamless transition. This upgrade allows us to scale our infrastructure significantly to support higher bandwidth requirements and enterprise growth.
Affected services