Back to overview
Maintenance

🛠 FRA Emergency Kernel Maintenance (NeoProtect)

Aug 22 at 10:00pm BST  –  Aug 22 at 11:00pm BST
Affected services
Neoprotect.net

Resolved
Aug 23 at 07:14am BST

They posted an update at Aug 23, 2025 - 00:00 UTC:

A fix has been implemented and we are monitoring the results.

Updated
Aug 23 at 12:55am BST

Neoprotect is experiencing network issues which are related to their last maintenance.

Services operating with Neoprotect might be interrupted or there might high latency.

More info: https://neoprotect.statuspage.io/incidents/qdmxlzvptgx8

Updated
Aug 22 at 11:54pm BST

The scheduled maintenance has been completed.

Created
Aug 22 at 10:00pm BST

Our DDoS mitigation partner NeoProtect will be performing emergency kernel maintenance in Frankfurt on Aug 22 between 22:00–23:00 UTC.
During this window, you may notice brief interruptions (up to a few minutes) as their edge nodes will restart. Protection capacity will remain available, and no extended downtime is expected.

More here: https://neoprotect.statuspage.io/incidents/w3vpj5y29k2v