Back to overview
Degraded

🚨 Premium VPS | NODE-3 | Storage Failure

Aug 20 at 09:25am BST
Affected services
[EU] - Premium VPS | NODE - 3

Resolved
Aug 20 at 12:30pm BST

Incident has been resolved.

Created
Aug 20 at 09:25am BST

We have identified a storage issue on VPS-NODE-3 and the server is currently under emergency maintenance. Our team is investigating and working to restore service as quickly as possible.