๐ง Scheduled Maintenance Notice โ Server Relocation ๐ง
Resolved
Jul 14 at 10:25pm BST
๐ Date: Monday, 14th July 2025
โฐ Time: 3:00 PM UTC
Maintenance Complete! ๐
We're excited to announce that the server relocation from Redditch, UK, to our new state-of-the-art data center in London, UK, has been successfully completed ahead of schedule. All services, including Game Servers and VPS, are now fully operational and running smoother than ever.
Key highlights from this upgrade:
- Faster network routing for reduced latency and improved performance.
- Enhanced stability and security to protect your data.
- Increased capacity to support your growing needs.
Our team has performed extensive system checks, and everything is verified to be stable. Your data and IP addresses remain unchanged, just as promised.
If you encounter any issues or have questions, our support team is standing by via live chat or ticket, don't hesitate to reach out.
Thank you for your patience during this essential upgrade. We're committed to delivering the best hosting experience possible!
Stay tuned for more updates on our status page.
Affected services
[EU] - UK Web Node
[N50] - UK Game Node #1
[SQL50] - UK Database Node #1
[EU] - Premium VPS | NODE - 14
[EU] - Premium VPS | NODE - 17
Created
Jul 14 at 10:00am BST
๐ Date: Monday, 14th July 2025
โฐ Time: 09:00 AM โ 2:00 PM UTC
At FREAKHOSTING, your service quality and security are our top priorities. To enhance our infrastructure, we are relocating our servers from Redditch, UK to a new, advanced data center in London, UK ๐ฌ๐งโจ
During this time:
- Services like Game Servers and VPS will be manually migrated to the new nodes.
- There will be intermittent downtime lasting several hours โ we appreciate your patience.
- Your data and IP addresses remain unchanged and secure.
- Please backup your data beforehand as a precaution.
We will be conducting thorough system checks after the migration to ensure everything runs flawlessly. Our support team will be available throughout the maintenance to assist you with any concerns.
This upgrade brings faster network routing, improved stability, enhanced security, and increased capacity to better serve you now and into the future.
We apologise for any inconvenience caused and thank you for your understanding. Real-time updates will be available on our status page.
No action is needed on your part beyond backing up your data โ weโve got the rest covered!
If you have questions, please contact support via live chat or ticket.
Affected services
[EU] - UK Web Node
[N50] - UK Game Node #1
[SQL50] - UK Database Node #1
[EU] - Premium VPS | NODE - 14
[EU] - Premium VPS | NODE - 17