BUDGET VPS NETWORK PERFORMANCE – GERMANY
Resolved
Jun 14 at 06:21pm BST
Update – 15/06/2025 – Frankfurt, Germany
We are pleased to confirm that the Budget VPS range is now fully operational and services across all customers should be functioning within normal parameters. Network performance has returned to expected levels, and all systems are stable.
If you are unable to access your VPS, please first ensure that it is powered on from the VPS Control Panel. In some cases, manual boot may still be required following the recent maintenance.
Should you continue to experience any issues, please open a support ticket or contact us via live chat. Our team will prioritise getting back to you as quickly as possible.
Thank you once again for your patience and understanding throughout this incident.
— The FREAKHOSTING Team
Affected services
[EU] - Budget VPS | NODE - 10
[EU] - Budget VPS | NODE - 13
[EU] - Budget VPS | NODE - 15
[EU] - Budget VPS | NODE - 16
[EU] - Budget VPS | NODE - 18
[EU] - Budget VPS | NODE - 101
[EU] - Budget VPS | NODE - 104
[EU] - Budget VPS | NODE - 105
[EU] - Budget VPS | NODE - 107
[EU] - Budget VPS | NODE - 108
[EU] - Budget VPS | NODE - 109
[EU] - Budget VPS | NODE - 110
[EU] - Budget VPS | NODE - 111
[EU] - Budget VPS | NODE - 113
[EU] - Budget VPS | NODE - 115
[EU] - Budget VPS | NODE - 116
[EU] - Budget VPS | NODE - 117
[EU] - Budget VPS | NODE - 118
[EU] - Budget VPS | NODE - 120
[EU] - Budget VPS | NODE - 119
[EU] - Budget VPS | NODE - 9
[EU] - Budget VPS | NODE - 123
[EU] - Budget VPS | NODE - 125
[EU] - Budget VPS | NODE - 126
[EU] - Budget VPS | NODE - 132
[EU] - Budget VPS | NODE - 133
[EU] - Budget VPS | NODE - 138
Updated
Jun 14 at 05:53pm BST
Update – 14/06/2025 – Frankfurt, Germany
We’ve now managed to bring all Budget VPS nodes to a significantly more stable state. While there may still be minor discrepancies in performance, they should no longer be critical or service-breaking.
At this stage, we strongly recommend all Budget VPS customers to log into the VPS Control Panel and attempt to boot their VPS. Please check if it is accessible and performing within normal parameters.
If you encounter any issues, don’t hesitate to reach out via support tickets or live chat. We’ll do our best to assist you as quickly as possible.
We sincerely apologize for the delay in responses — our team is currently handling over 3,000 support conversations, which has caused significant strain on our response times. Thank you for your patience and understanding.
Affected services
[EU] - Budget VPS | NODE - 10
[EU] - Budget VPS | NODE - 13
[EU] - Budget VPS | NODE - 15
[EU] - Budget VPS | NODE - 16
[EU] - Budget VPS | NODE - 18
[EU] - Budget VPS | NODE - 101
[EU] - Budget VPS | NODE - 104
[EU] - Budget VPS | NODE - 105
[EU] - Budget VPS | NODE - 107
[EU] - Budget VPS | NODE - 108
[EU] - Budget VPS | NODE - 109
[EU] - Budget VPS | NODE - 110
[EU] - Budget VPS | NODE - 111
[EU] - Budget VPS | NODE - 113
[EU] - Budget VPS | NODE - 115
[EU] - Budget VPS | NODE - 116
[EU] - Budget VPS | NODE - 117
[EU] - Budget VPS | NODE - 118
[EU] - Budget VPS | NODE - 120
[EU] - Budget VPS | NODE - 119
[EU] - Budget VPS | NODE - 9
[EU] - Budget VPS | NODE - 123
[EU] - Budget VPS | NODE - 125
[EU] - Budget VPS | NODE - 126
[EU] - Budget VPS | NODE - 132
[EU] - Budget VPS | NODE - 133
[EU] - Budget VPS | NODE - 138
Updated
Jun 14 at 03:29pm BST
Update – 14/06/2025 – Frankfurt, Germany
We have successfully restored optimal network performance for a portion of the affected Budget VPS servers in Germany. However, a few instances are still experiencing connectivity issues, and our team is actively working to resolve them.
Please note that your Budget VPS may temporarily go offline during this process. If that happens, we recommend accessing your VPS Control Panel and manually powering it back on.
This is one of the most significant network issues we've encountered, and we understand the frustration it may be causing. Rest assured, our team is doing everything possible to fully stabilize the situation as soon as possible.
Thank you once again for your continued patience and understanding.
— The FREAKHOSTING Team
Affected services
[EU] - Budget VPS | NODE - 10
[EU] - Budget VPS | NODE - 13
[EU] - Budget VPS | NODE - 15
[EU] - Budget VPS | NODE - 16
[EU] - Budget VPS | NODE - 18
[EU] - Budget VPS | NODE - 101
[EU] - Budget VPS | NODE - 104
[EU] - Budget VPS | NODE - 105
[EU] - Budget VPS | NODE - 107
[EU] - Budget VPS | NODE - 108
[EU] - Budget VPS | NODE - 109
[EU] - Budget VPS | NODE - 110
[EU] - Budget VPS | NODE - 111
[EU] - Budget VPS | NODE - 113
[EU] - Budget VPS | NODE - 115
[EU] - Budget VPS | NODE - 116
[EU] - Budget VPS | NODE - 117
[EU] - Budget VPS | NODE - 118
[EU] - Budget VPS | NODE - 120
[EU] - Budget VPS | NODE - 119
[EU] - Budget VPS | NODE - 9
[EU] - Budget VPS | NODE - 123
[EU] - Budget VPS | NODE - 125
[EU] - Budget VPS | NODE - 126
[EU] - Budget VPS | NODE - 132
[EU] - Budget VPS | NODE - 133
[EU] - Budget VPS | NODE - 138
Created
Jun 14 at 10:00am BST
Date: 14/06/2025
Location: Frankfurt, Germany
We are currently investigating a network issue affecting a portion of our Budget VPS services in Germany. Some customers may be experiencing frequent packet drops or high latency, while others remain unaffected.
At this time, the root cause is still under investigation. Unfortunately, due to it being a Saturday, both our internal team and the datacenter’s support team are operating with limited capacity, which is slowing down diagnostics and resolution.
We sincerely apologize if we haven’t responded to all inquiries — our current priority is identifying and mitigating the issue as quickly as possible.
Further updates will be shared as soon as we have more information. Thank you for your patience and understanding.
— The FREAKHOSTING Team
Affected services
[EU] - Budget VPS | NODE - 10
[EU] - Budget VPS | NODE - 13
[EU] - Budget VPS | NODE - 15
[EU] - Budget VPS | NODE - 16
[EU] - Budget VPS | NODE - 18
[EU] - Budget VPS | NODE - 101
[EU] - Budget VPS | NODE - 104
[EU] - Budget VPS | NODE - 105
[EU] - Budget VPS | NODE - 107
[EU] - Budget VPS | NODE - 108
[EU] - Budget VPS | NODE - 109
[EU] - Budget VPS | NODE - 110
[EU] - Budget VPS | NODE - 111
[EU] - Budget VPS | NODE - 113
[EU] - Budget VPS | NODE - 115
[EU] - Budget VPS | NODE - 116
[EU] - Budget VPS | NODE - 117
[EU] - Budget VPS | NODE - 118
[EU] - Budget VPS | NODE - 120
[EU] - Budget VPS | NODE - 119
[EU] - Budget VPS | NODE - 9
[EU] - Budget VPS | NODE - 123
[EU] - Budget VPS | NODE - 125
[EU] - Budget VPS | NODE - 126
[EU] - Budget VPS | NODE - 132
[EU] - Budget VPS | NODE - 133
[EU] - Budget VPS | NODE - 138